Data Updates Delayed
Resolved
Aug 17, 2026 at 7:57pm UTC
Issue has been resolved, and most customers should see updated data, with a few remaining still flowing in. We appreciate your patience!
Affected services
Updated
Aug 17, 2026 at 6:25pm UTC
Third party outage has been resolved, and data is beginning to flow in for all customers.
Affected services
Created
Aug 17, 2026 at 3:54pm UTC
Due to an outage in a third party system, data updates for today in Analytics are currently delayed (Explorer data is unaffected). No data in Analytics will be lost during this time, and all data will back-fill once the issue is resolved. We will provide updates as more information becomes available.
Affected services