Back to overview
Degraded

Azure billing connections delayed in platform

Jan 08 at 01:22pm EST
Affected services
app.cloudzero.com

Resolved
Jan 08 at 02:30pm EST

We have identified and rectified the root cause of this issue. All Azure connections are up to date or currently ingesting data, and will be available in the CloudZero platform alongside their respective billing data as soon as our normal nightly billing ingest cycle completes.

Created
Jan 08 at 01:22pm EST

Azure billing connections are delayed in retrieving cost data for the prior 48 hours. We are actively investigating root cause and will provide an update as soon as possible.