Back to overview
Degraded

Unit Cost Data Delayed

Mar 23, 2026 at 03:57pm UTC
Affected services
app.cloudzero.com

Resolved
Mar 23, 2026 at 11:59pm UTC

The root cause has been identified and resolved. The unit cost ingest has been re-run for all affected organizations, and the system is back to normal operation. Any remaining data gaps will be resolved upon the next scheduled materialization run.

Created
Mar 23, 2026 at 03:57pm UTC

The unit cost ingest pipeline experienced delays starting March 19, 2026, which may result in some organizations seeing stale or missing unit cost data in their telemetry allocation dimensions. Engineering has identified the issue and is actively working to restore normal ingestion.