Back to overview
Downtime
Some users having issues logging in
Apr 20, 2026 at 5:55pm UTC
Affected services
app.cloudzero.com
Resolved
Apr 20, 2026 at 6:28pm UTC
The fix has been rolled out, and we are testing and monitoring. Initial tests have been successful, we will continue to watch.
Affected services
Updated
Apr 20, 2026 at 6:24pm UTC
A fix is being rolled out and tested.
Affected services
Created
Apr 20, 2026 at 5:55pm UTC
We are getting reports of users getting a "you must verify your email address" when logging into CloudZero via SSO.
We've identified the issue and are working on a fix.
Affected services