Back to overview
Resolved

Azure Data Delayed

May 26, 2026 at 4:38pm UTC
Affected services
app.cloudzero.com

Resolved
May 27, 2026 at 3:08pm UTC

This issue has been patched and data has been backfilled accordingly.

Updated
May 26, 2026 at 7:46pm UTC

The issue has been identified and resolved. Data is flowing normally, and we are backfilling impacted accounts. No data was lost — the issue was contained to our pipeline, and your underlying data remained intact.

Created
May 26, 2026 at 4:38pm UTC

We are getting increased reports of some customers seeing a delay in Azure data appearing in the platform. We are aware of this issue and are taking steps to address it.