Delayed Kubernetes Data
Resolved
Sep 14 at 10:35pm EDT
The backfill of incomplete data has been completed. We appreciate your patience as we worked to resolve this issue.
Affected services
app.cloudzero.com
Updated
Sep 14 at 07:00am EDT
As of Saturday morning, we are continuing to actively back-fill Kubernetes container metrics for select date ranges in August. We have all of the necessary container metric data; we are in the process of ingesting it properly so that it can be tied up with the associated cost data.
The backfill continues to progress as expected, and we remain confident that this will be completed and in a watching state later today (9/14).
Affected services
app.cloudzero.com
Updated
Sep 13 at 10:30am EDT
We are continuing to actively back-fill Kubernetes container metrics for select date ranges in August, as we've observed small gaps across 8/16 - 8/22 and 8/28 - 8/31. We have all of the necessary container metric data; we just need to ingest it properly so that it can be tied up with the associated cost data.
The backfill continues to progress well, and we remain confident that this will be completed and in a watching state on 9/14.
Affected services
app.cloudzero.com
Updated
Sep 12 at 11:00am EDT
We continue to actively back-fill Kubernetes container metric select date ranges in August, as we've observed small gaps across 8/16 - 8/22 and 8/28 - 8/31. We have all of the necessary container metric data; we just need to ingest it properly so that it can be tied up with the associated cost data. The backfill is going well, and is expected to be completed and in a watching state on 9/14.
Affected services
app.cloudzero.com
Updated
Sep 11 at 05:00pm EDT
Proper Kubernetes container metrics continue to flow into the CloudZero platform for all customers.
We continue to actively back-fill select date ranges in August, as we've observed small gaps across 8/16 - 8/22 and 8/28 - 8/31. We have all of the necessary container metric data; we just need to ingest it properly so that it can be tied up with the associated cost data.
In addition, we're looking at an issue impacting a subset of customers where our cost algorithm appears to be incorrectly assigning Idle costs for Kubernetes clusters.
Affected services
app.cloudzero.com
Updated
Sep 11 at 07:45am EDT
Proper Kubernetes container metrics are now flowing in for all CloudZero customers, and these are being used to correctly allocate compute costs.
We have observed that we need to selectively back-fill a few date ranges, as we're seeing small gaps across 8/16 - 8/22 and 8/28 - 8/31. We have all of the necessary container metric data; we just need to ingest it properly so that it can be tied up with the associated cost data.
Affected services
app.cloudzero.com
Updated
Sep 10 at 07:51pm EDT
We are continuing to work on fully resolving a known issue when ingesting container usage data for Kubernetes customers, which results in a delay in seeing new Kubernetes clusters or updated container usage statistics.
We have identified the root cause, deployed a fix, and are finalizing changes to ensure all cost and container usage data is up to date and available in the CloudZero platform. We expect this issue to be fully resolved by Wed, Sep 11 at 10 AM ET.
Affected services
app.cloudzero.com
Created
Sep 09 at 03:54pm EDT
Currently, there is a known issue ingesting usage data for Kubernetes customers. This issue has resulted in a delay in seeing new Kubernetes clusters or updated usage statistics. We have identified the root cause, deployed a fix, and are working on backfilling the affected data.
Affected services
app.cloudzero.com