Back to overview
Degraded

Snowflake Billing Connection Errors

Sep 17 at 11:55am EDT
Affected services
app.cloudzero.com

Resolved
Sep 17 at 09:00pm EDT

This issue has now been fully resolved. We appreciate your patience as we worked to a full resolution.

Updated
Sep 17 at 06:30pm EDT

We have made Snowflake billing data visible for 75% of impacted customers, and are continuing to ingest this data for the remaining impacted customers.

Updated
Sep 17 at 03:00pm EDT

We have fixed the root cause of this issue impacting and are actively running ingest processes so that our customers will see their Snowflake billing data in the platform as soon as possible.

Updated
Sep 17 at 12:30pm EDT

We have identified the root cause of this issue and a fix is actively in progress.

Created
Sep 17 at 11:55am EDT

We are aware of and investigating an issue with failed Snowflake billing connections in the CloudZero platform. We are working to fix this problem as quickly as we can, and will share another update shortly.