Back to overview
Degraded

Delayed Datadog Billing Data

Nov 08 at 10:00am EST
Affected services
app.cloudzero.com

Resolved
Nov 09 at 01:00pm EST

Datadog has provided a workaround for this behavior for the time being. Please consult your FinOps Account Manager for steps to remediate as needed. We will continue to assist Datadog with troubleshooting in the meantime.

Updated
Nov 08 at 05:30pm EST

We continue to work with our contacts at Datadog to identify and resolve the root cause of this issue.

Created
Nov 08 at 10:00am EST

For a small subset of our customers, with Datadog billing connections outside of the Datadog US1 (datadoghq.com) region, we are currently unable to receive billing data. We are working closely with Datadog on this issue.