Back to overview
Degraded

Some billing connections delayed in CloudZero platform

Nov 25 at 10:30am EST
Affected services
app.cloudzero.com

Resolved
Nov 25 at 11:45am EST

We have identified and mitigated the root cause, and have triggered processes to ingest the latest billing data for all impacted billing connections. We expect all billing data to be caught up shortly.

Created
Nov 25 at 10:30am EST

A limited number of billing connections (for cloud service providers Databricks, Datadog, MongoDB, and New Relic) are delayed in retrieving cost data. We are actively investigating root cause and will provide an update as soon as possible.