Back to overview
Degraded

GCP Billing Data Delayed

Apr 28 at 05:00pm EDT
Affected services
app.cloudzero.com

Resolved
May 02 at 08:26am EDT

We’re now seeing GCP billing data flow normally across all CloudZero customers. If you continue to experience any issues, please don’t hesitate to reach out to our support team. Thanks for your patience while we monitored this situation.

Updated
Apr 30 at 03:17pm EDT

We’re seeing fresh data starting to load from Google Cloud Platform (GCP), but some delays are still present for a subset of GCP customers. We’re actively monitoring the situation alongside our partners at Google and will share another update once things are fully back to normal.

Created
Apr 28 at 05:00pm EDT

Google Cloud Platform (GCP) has informed CloudZero and other customers that, beginning on April 25, 2025, they are experiencing delays in delivering cost data for some organizations.

We encourage you to contact GCP support directly if you have any questions or concerns. CloudZero will continue to actively monitor the situation and provide updates as necessary.